Page 1 of 1

Testing the new TSE X50 V2

Posted: Fri Jun 13, 2014 3:49 pm
by theplague
This is a great sim. i've only had it for about a week, but i am very happy with the capabilities of this software. here's a test riff i've been using to try and dial in the tone i'm looking for.
https://www.dropbox.com/s/84b9sjuo5qqesb3/x50test3.wav

Re: Testing the new TSE X50 V2

Posted: Sat Jun 14, 2014 12:46 pm
by theplague
For this riff I dropped the channel eq in Logic Pro X and only used X50 eq. The IR is the same as in the other riff. Drums are EZdrummer 2 and bass is Koloss Bass from Toontrack Metal Gods EZX. I am still trying to dial in the eq on this particular IR which I created myself. I'm trying to get closer to a true power amp based tone than preamp based.
https://www.dropbox.com/s/sva05wsx6rhwgo9/x50n4.wav

Re: Testing the new TSE X50 V2

Posted: Wed Jun 18, 2014 2:55 am
by theplague
Almost there. all guitars done with X50, except bass...using Koloss preset from toontrack Metal Gods EZX
https://www.dropbox.com/s/0wkmbhv04wlqoyz/x50617.wav
hope you all like it. i love recording :)

Re: Testing the new TSE X50 V2

Posted: Wed Jun 18, 2014 9:08 am
by texisthebest
Good job, maybe the guitar tone is too dark to my taste, you could try adding a high shelf

Re: Testing the new TSE X50 V2

Posted: Fri Jun 20, 2014 1:34 am
by theplague
hey thanks for the feedback! this one is the same music using the Diezel impulse on the rhythm guitars.
https://www.dropbox.com/s/09vpu9ogrwnvr ... elTest.wav

Re: Testing the new TSE X50 V2

Posted: Wed Jun 25, 2014 3:48 pm
by theplague
Here's a short piece with dual lead guitars. Rhythm guitars are then X50 with my own IR. The leads are X50 using another preset of my own with Logic Pro X delay insert. Both rhythm guitars are panned hard L and R as are the leads. Bass is the usual Koloss bass that I love.
https://www.dropbox.com/s/kfslr7200lzyl ... eadX50.wav

Re: Testing the new TSE X50 V2

Posted: Sun Jun 29, 2014 8:34 pm
by theplague
I put together a full song entitled Fall of Titans. enjoy!
https://www.dropbox.com/s/yz22hpxcmv0jj ... Titans.wav

Re: Testing the new TSE X50 V2

Posted: Tue Aug 25, 2015 7:43 pm
by wakeguitar
i love this plug, especially i load the second preset to get the revise X30 amp. Then use the low gain channel and play with bright and gain. Nice.

I have however come across a couple issues, I think with Cubase - the cabs don't seem to reload properly in Cubase7 32bit.
Also there is no easy method to switch between the x30 and x50 without loading a whole new preset via the preset page...
The cabinets here are fantastic, I just wish the .vstpreset would load properly!

Re: Testing the new TSE X50 V2

Posted: Tue Aug 25, 2015 7:55 pm
by wakeguitar
i love this plug, especially i load the second preset to get the revise X30 amp. Then use the low gain channel and play with bright and gain and eq.

Re: Testing the new TSE X50 V2

Posted: Thu Nov 24, 2016 2:08 am
by wakeguitar
update: it's been nice using new version (at v2.4.5) but unfortunately still some issues of crashing in Cubase 8.5 64 bits.. Pretty sure it's related to the quality settings on mix down... hope this can be addressed in next patch :)